# CVE-2021-46708: Spoofing attack in swagger-ui-dist

> Remote attackers can hijack user click actions in swagger-ui-dist by luring victims to malicious sites, potentially enabling further attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** CLSA-2026-1786375655, GHSA-6c9x-mj3g-h47x

## What is CVE-2021-46708?

CVE-2021-46708 is a medium-severity vulnerability in n/a, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The swagger-ui-dist package before 4.1.3 for Node.js could allow a remote attacker to hijack the clicking action of the victim. By persuading a victim to visit a malicious Web site, a remote attacker could exploit this vulnerability to hijack the victim's click actions and possibly launch further attacks against the victim.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2021-46708?

2 open source packages ship an affected version, including swagger-ui-dist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swagger-ui-dist` | npm | All versions | 4.1.3 |
| `swagger-ui-dist` | npm | All versions | 4.1.3 |

Products: Smartbear Swagger-Ui-Dist.

## How do I fix CVE-2021-46708?

Upgrade swagger-ui-dist to 4.1.3 or later.

## Is CVE-2021-46708 being exploited?

There is no known exploitation of CVE-2021-46708 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46708 and fix it if it is affected.

What it is: CVE-2021-46708 is a medium-severity vulnerability in n/a, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-46708 in the wild and no public exploit code.

Affected packages and fixed versions:
- swagger-ui-dist (npm): affected all versions; fixed in 4.1.3
- swagger-ui-dist (npm): affected all versions; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46708/ (Markdown: https://insights.sbomify.com/CVE-2021-46708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46708
- OSV: https://osv.dev/vulnerability/CVE-2021-46708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46708/
Summaries are generated and may contain mistakes; the official description above is the record.
