# CVE-2021-46743: Firebase PHP-JWT key/algorithm type confusion

> Attackers can forge JWT tokens by exploiting algorithm confusion in the kid header when multiple key types are loaded, bypassing authentication.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8xf4-w7qw-pjjw

## What is CVE-2021-46743?

CVE-2021-46743 is a critical vulnerability in n/a, published on 29 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Firebase PHP-JWT before 6.0.0, an algorithm-confusion issue (e.g., RS256 / HS256) exists via the kid (aka Key ID) header, when multiple types of keys are loaded in a key ring. This allows an attacker to forge tokens that validate under the incorrect key. NOTE: this provides a straightforward way to use the PHP-JWT library unsafely, but might not be considered a vulnerability in the library itself.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2021-46743?

2 open source packages ship an affected version, including firebase/php-jwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `firebase/php-jwt` | Packagist | All versions | 6.0.0 |
| `firebase/php-jwt` | Packagist | All versions | 6.0.0 |

Products: Google Firebase Php-Jwt.

## How do I fix CVE-2021-46743?

Upgrade firebase/php-jwt to 6.0.0 or later.

## Is CVE-2021-46743 being exploited?

There is no known exploitation of CVE-2021-46743 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-45769](https://insights.sbomify.com/CVE-2025-45769/): php-jwt contains weak encryption (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46743 and fix it if it is affected.

What it is: CVE-2021-46743 is a critical vulnerability in n/a, published on 29 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-46743 in the wild and no public exploit code.

Affected packages and fixed versions:
- firebase/php-jwt (Packagist): affected all versions; fixed in 6.0.0
- firebase/php-jwt (Packagist): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46743/ (Markdown: https://insights.sbomify.com/CVE-2021-46743/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46743
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46743
- OSV: https://osv.dev/vulnerability/CVE-2021-46743

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46743/
Summaries are generated and may contain mistakes; the official description above is the record.
