# CVE-2021-46823: Denial of Service in python-ldap

> A remote authenticated attacker can cause a denial of service in python-ldap by sending crafted regex input to the schema parser.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2022
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-9960, DEBIAN-CVE-2021-46823, GHSA-qfr5-wjpw-q4c4, GHSA-r8wq-qrxc-hmcm, MGASA-2022-0310, OESA-2022-1792, OESA-2022-1809, PYSEC-2026-912, UBUNTU-CVE-2021-46823, USN-5508-1

## What is CVE-2021-46823?

CVE-2021-46823 is a medium-severity denial of service vulnerability in n/a, published on 18 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

python-ldap before 3.4.0 is vulnerable to a denial of service when ldap.schema is used for untrusted schema definitions, because of a regular expression denial of service (ReDoS) flaw in the LDAP schema parser. By sending crafted regex input, a remote authenticated attacker could exploit this vulnerability to cause a denial of service condition.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-46823?

5 open source packages ship an affected version, including python-ldap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-ldap` | PyPI | All versions | 3.4.0 |
| `python-ldap` | PyPI | All versions | 3.4.0 |
| `python-ldap` | PyPI | All versions | 3.4.0 |
| `python-ldap` | PyPI | All versions | 3.4.0 |
| `python-ldap` | PyPI | All versions | 3.4.0 |

Products: Python-Ldap Python-Ldap.

## How do I fix CVE-2021-46823?

Upgrade python-ldap to 3.4.0 or later.

## Is CVE-2021-46823 being exploited?

There is no known exploitation of CVE-2021-46823 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-61911](https://insights.sbomify.com/CVE-2025-61911/): python-ldap has sanitization bypass in ldap.filter.escape_filter_chars (medium 5.5)
- [CVE-2025-61912](https://insights.sbomify.com/CVE-2025-61912/): python-ldap Vulnerable to Improper Encoding or Escaping of Output and Improper Null Termination (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46823 and fix it if it is affected.

What it is: CVE-2021-46823 is a medium-severity denial of service vulnerability in n/a, published on 18 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-46823 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-ldap (PyPI): affected all versions; fixed in 3.4.0
- python-ldap (PyPI): affected all versions; fixed in 3.4.0
- python-ldap (PyPI): affected all versions; fixed in 3.4.0
- python-ldap (PyPI): affected all versions; fixed in 3.4.0
- python-ldap (PyPI): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46823/ (Markdown: https://insights.sbomify.com/CVE-2021-46823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46823
- OSV: https://osv.dev/vulnerability/CVE-2021-46823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46823/
Summaries are generated and may contain mistakes; the official description above is the record.
