# CVE-2021-46871: phoenix_html allows Cross-site Scripting in HEEx class attributes

> Cross-site scripting vulnerability in Phoenix.HTML allows attackers to inject malicious scripts via HEEx class attributes.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2023
- **Updated:** 9 Apr 2025
- **Also known as:** GHSA-5g2h-9x5v-5h3x, GHSA-j3gg-r6gp-95q2

## What is CVE-2021-46871?

CVE-2021-46871 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

tag.ex in Phoenix Phoenix.HTML (aka phoenix_html) before 3.0.4 allows XSS in HEEx class attributes.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-46871?

6 open source packages ship an affected version, including phoenix_html. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phoenix_html` | Hex | All versions | 3.0.4 |
| `phoenix_html` | Hex | All versions | 3.0.4 |
| `phoenix_html` | Hex | All versions | 3.0.4 |
| `phoenix_html` | Hex | All versions | 3.0.4 |
| `phoenix_html` | npm | All versions | 3.0.4 |
| `phoenix_html` | npm | All versions | 3.0.4 |

Products: Phoenixframework Phoenix Html.

## How do I fix CVE-2021-46871?

Upgrade phoenix_html to 3.0.4 or later.

## Is CVE-2021-46871 being exploited?

There is no known exploitation of CVE-2021-46871 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46871 and fix it if it is affected.

What it is: CVE-2021-46871 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-46871 in the wild and no public exploit code.

Affected packages and fixed versions:
- phoenix_html (Hex): affected all versions; fixed in 3.0.4
- phoenix_html (Hex): affected all versions; fixed in 3.0.4
- phoenix_html (Hex): affected all versions; fixed in 3.0.4
- phoenix_html (Hex): affected all versions; fixed in 3.0.4
- phoenix_html (npm): affected all versions; fixed in 3.0.4
- phoenix_html (npm): affected all versions; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46871/ (Markdown: https://insights.sbomify.com/CVE-2021-46871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46871
- OSV: https://osv.dev/vulnerability/CVE-2021-46871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46871/
Summaries are generated and may contain mistakes; the official description above is the record.
