# CVE-2021-46877: jackson-databind possible Denial of Service if using JDK serialization to serialize JsonNode

> Attackers can cause denial of service via excessive heap usage in jackson-databind during JsonNode JDK serialization.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2023
- **Updated:** 26 Feb 2025
- **Also known as:** DEBIAN-CVE-2021-46877, GHSA-3x8x-79m2-3w2w, MINI-6p6p-mg4p-vvqr, ROOT-APP-MAVEN-CVE-2021-46877, UBUNTU-CVE-2021-46877

## What is CVE-2021-46877?

CVE-2021-46877 is a high-severity denial of service vulnerability in Fasterxml Jackson-Databind, published on 18 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jackson-databind 2.10.x through 2.12.x before 2.12.6 and 2.13.x before 2.13.1 allows attackers to cause a denial of service (2 GB transient heap usage per read) in uncommon situations involving JsonNode JDK serialization.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2021-46877?

4 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.10.0 | 2.12.6 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.10.0 | 2.12.6 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.13.0 | 2.13.1 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.13.0 | 2.13.1 |

Products: Fasterxml Jackson-Databind.

## How do I fix CVE-2021-46877?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.12.6 or 2.13.1.

## Is CVE-2021-46877 being exploited?

There is no known exploitation of CVE-2021-46877 in the wild and no public exploit code.

## Other vulnerabilities in Fasterxml Jackson-Databind

- [CVE-2018-11307](https://insights.sbomify.com/CVE-2018-11307/): Deserialization of Untrusted Data in jackson-databind (critical 9.8)
- [CVE-2026-54512](https://insights.sbomify.com/CVE-2026-54512/): jackson-databind: PolymorphicTypeValidator bypass via generic type parameters allows arbitrary class instantiation (high 8.1)
- [CVE-2026-54513](https://insights.sbomify.com/CVE-2026-54513/): jackson-databind: Array subtype allowlist bypass in BasicPolymorphicTypeValidator (allowIfSubTypeIsArray) (high 8.1)
- [CVE-2020-14060](https://insights.sbomify.com/CVE-2020-14060/): Deserialization of untrusted data in Jackson Databind (high 8.1)
- [CVE-2019-14893](https://insights.sbomify.com/CVE-2019-14893/): Polymorphic deserialization of malicious object in jackson-databind (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46877 and fix it if it is affected.

What it is: CVE-2021-46877 is a high-severity denial of service vulnerability in Fasterxml Jackson-Databind, published on 18 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-46877 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.10.0; fixed in 2.12.6
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.10.0; fixed in 2.12.6
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.13.0; fixed in 2.13.1
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.13.0; fixed in 2.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46877/ (Markdown: https://insights.sbomify.com/CVE-2021-46877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46877
- OSV: https://osv.dev/vulnerability/CVE-2021-46877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46877/
Summaries are generated and may contain mistakes; the official description above is the record.
