# CVE-2021-46879: Memory corruption in n/a

> A heap overflow in Fluent Bit allows attackers to execute arbitrary code by tricking users into opening a malicious file.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Apr 2023
- **Updated:** 11 Feb 2025
- **Also known as:** BIT-fluent-bit-2021-46879, GHSA-m8h6-32jj-7hxp

## What is CVE-2021-46879?

CVE-2021-46879 is a high-severity memory corruption vulnerability in n/a, published on 11 Apr 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Treasure Data Fluent Bit 1.7.1, a wrong variable is used to get the msgpack data resulting in a heap overflow in flb_msgpack_gelf_value_ext. An attacker can craft a malicious file and tick the victim to open the file with the software, triggering a heap overflow and execute arbitrary code on the target system.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-46879?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 1.7.1 | 1.7.2 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2021-46879?

Upgrade fluent-bit to 1.7.2 or later.

## Is CVE-2021-46879 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-46879 exists.

## Other vulnerabilities in n/a

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46879 and fix it if it is affected.

What it is: CVE-2021-46879 is a high-severity memory corruption vulnerability in n/a, published on 11 Apr 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-46879 exists.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 1.7.1; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46879/ (Markdown: https://insights.sbomify.com/CVE-2021-46879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46879
- OSV: https://osv.dev/vulnerability/CVE-2021-46879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46879/
Summaries are generated and may contain mistakes; the official description above is the record.
