# CVE-2021-46897: Wagtail CRX CodeRed Extensions vulnerable to Path Traversal

> Attackers can bypass protection to read protected media files via path traversal in the Wagtail CRX extension.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2023
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h454-rq3m-89rc, PYSEC-2023-210

## What is CVE-2021-46897?

CVE-2021-46897 is a medium-severity path traversal vulnerability in n/a, published on 22 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

views.py in Wagtail CRX CodeRed Extensions (formerly CodeRed CMS or coderedcms) before 0.22.3 allows upward protected/..%2f..%2f path traversal when serving protected media.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-46897?

3 open source packages ship an affected version, including coderedcms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `coderedcms` | PyPI | All versions | 0.22.3 |
| `coderedcms` | PyPI | All versions | 0.22.3 |
| `coderedcms` | PyPI | All versions | 0.22.3 |

Products: Wagtailcrx Codered Extensions.

## How do I fix CVE-2021-46897?

Upgrade coderedcms to 0.22.3 or later.

## Is CVE-2021-46897 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-46897 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46897 and fix it if it is affected.

What it is: CVE-2021-46897 is a medium-severity path traversal vulnerability in n/a, published on 22 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-46897 exists.

Affected packages and fixed versions:
- coderedcms (PyPI): affected all versions; fixed in 0.22.3
- coderedcms (PyPI): affected all versions; fixed in 0.22.3
- coderedcms (PyPI): affected all versions; fixed in 0.22.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46897/ (Markdown: https://insights.sbomify.com/CVE-2021-46897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46897
- OSV: https://osv.dev/vulnerability/CVE-2021-46897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46897/
Summaries are generated and may contain mistakes; the official description above is the record.
