{"answers":{"affected":"5 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-47935 exists.","fix":"Upgrade sentry to a fixed version for your release line: 8.1.4 or 8.2.2.","what":"CVE-2021-47935 is a high-severity unsafe deserialization vulnerability in Sentry, published on 10 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-47935 and fix it if it is affected.\n\nWhat it is: CVE-2021-47935 is a high-severity unsafe deserialization vulnerability in Sentry, published on 10 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-47935 exists.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected all versions up to 8.2.0; no fix listed\n- sentry (PyPI): affected all versions; fixed in 8.1.4\n- sentry (PyPI): affected all versions; fixed in 8.1.4\n- sentry (PyPI): affected from 8.2.0; fixed in 8.2.2\n- sentry (PyPI): affected from 8.2.0; fixed in 8.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-47935/ (Markdown: https://insights.sbomify.com/CVE-2021-47935/index.md)","id":"CVE-2021-47935","markdown":"https://insights.sbomify.com/CVE-2021-47935/index.md","name":"CVE-2021-47935","record":{"aliases":["GHSA-444r-2whx-3685","PYSEC-2026-131"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry error tracking","requires_auth":"low_privilege","summary":"Authenticated superusers can execute arbitrary code by injecting malicious pickle payloads into the audit log data parameter.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Sentry 8.2.0 contains a remote code execution vulnerability that allows authenticated superusers to execute arbitrary commands by injecting malicious pickle-serialized objects through the audit log entry data parameter. Attackers can submit crafted POST requests to the admin audit log endpoint with base64-encoded compressed pickle payloads in the data field to achieve code execution with application privileges.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2021"},"n_packages":5,"n_references":3,"next":{"headline":"OpenCATS 0.9.4 Remote Code Execution via Resume Upload","id":"CVE-2021-47936"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["8.2.0"],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2026-131"},{"ecosystem":"PyPI","fixed":["8.1.4"],"introduced":["0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-444r-2whx-3685"},{"ecosystem":"PyPI","fixed":["8.1.4"],"introduced":["0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-444r-2whx-3685"},{"ecosystem":"PyPI","fixed":["8.2.2"],"introduced":["8.2.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-444r-2whx-3685"},{"ecosystem":"PyPI","fixed":["8.2.2"],"introduced":["8.2.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-444r-2whx-3685"}],"prev":{"headline":"MyBB Timeline Plugin 1.0 Cross-Site Scripting and CSRF","id":"CVE-2021-47934"},"products":["Sentry"],"published":"2026-05-10","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.1,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","kev_date_added":null,"published":"2026-02-21"},{"cvss_score":8.1,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":7.7,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":7.3,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","kev_date_added":null,"published":"2024-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["Sentry"]},"summary":"Authenticated superusers can execute arbitrary code by injecting malicious pickle payloads into the audit log data parameter.","url":"https://insights.sbomify.com/CVE-2021-47935/"}