# CVE-2021-48006: PocketMine-MP before 4.0.3 Operator Privilege Escalation via Case Sensitivity

> Attackers can retain operator privileges after deop command due to case-sensitive matching failure in PocketMine-MP server software.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5mrr-24gh-4jwh, GHSA-j5qg-w9jg-3wg3

## What is CVE-2021-48006?

CVE-2021-48006 is a medium-severity vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PocketMine-MP before 4.0.3 does not perform case-insensitive matching when removing operator entries from ops.txt. The removeOp function lowercases the supplied name but only removes an exactly matching entry, so an operator name stored with non-lowercase letters cannot be revoked using the deop command, leaving the player as an operator until the entry is removed from ops.txt manually.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2021-48006?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.0.3 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.0.3 |

## How do I fix CVE-2021-48006?

Upgrade pocketmine/pocketmine-mp to 4.0.3 or later.

## Is CVE-2021-48006 being exploited?

There is no known exploitation of CVE-2021-48006 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-48006 and fix it if it is affected.

What it is: CVE-2021-48006 is a medium-severity vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-48006 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.0.3
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-48006/ (Markdown: https://insights.sbomify.com/CVE-2021-48006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-48006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-48006
- OSV: https://osv.dev/vulnerability/CVE-2021-48006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-48006/
Summaries are generated and may contain mistakes; the official description above is the record.
