{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2021-48007 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to 3.18.1 or later.","what":"CVE-2021-48007 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-48007 and fix it if it is affected.\n\nWhat it is: CVE-2021-48007 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-48007 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.18.1\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-48007/ (Markdown: https://insights.sbomify.com/CVE-2021-48007/index.md)","id":"CVE-2021-48007","markdown":"https://insights.sbomify.com/CVE-2021-48007/index.md","name":"CVE-2021-48007","record":{"aliases":["GHSA-556r-f58w-q4pf","GHSA-fm35-jgg3-3grx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"low_privilege","summary":"Attackers can crash PocketMine-MP servers or disrupt client rendering by sending crafted movement packets with invalid floating-point values.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"PocketMine-MP versions before 3.18.1 fail to validate NaN or INF values in MovePlayerPacket position and rotation fields. Malicious clients can send crafted movement packets with invalid floating-point values to crash servers through unhandled mathematical operations or prevent clients from rendering other players.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 3.18.1 Denial of Service via MovePlayerPacket","id":"CVE-2021-48007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Chanjet CRM SQL Injection via get_usedspace.php","id":"CVE-2021-48008"},"packages":[{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-fm35-jgg3-3grx"},{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-fm35-jgg3-3grx"}],"prev":{"headline":"PocketMine-MP before 4.0.3 Operator Privilege Escalation via Case Sensitivity","id":"CVE-2021-48006"},"products":["PocketMine-MP"],"published":"2026-09-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Attackers can crash PocketMine-MP servers or disrupt client rendering by sending crafted movement packets with invalid floating-point values.","url":"https://insights.sbomify.com/CVE-2021-48007/"}