# CVE-2021-48018: Vyper 0.2.13 before 0.2.15 Storage Corruption via @nonreentrant Decorator


- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-57w3-rr8j-wp9c, GHSA-7f92-rr6w-cq64

## What is CVE-2021-48018?

CVE-2021-48018 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. 

### Official description

Vyper from 0.2.13 before 0.2.15 allocates storage slots for @nonreentrant reentrancy locks at the same locations as contract storage variables. When a function using @nonreentrant is called, setting the lock overwrites the overlapping storage variable, corrupting contract state and breaking the contract's intended logic.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-48018?

2 open source packages ship an affected version, including vyper.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | From 0.2.13 | 0.2.15 |
| `vyper` | PyPI | From 0.2.13 | 0.2.15 |

## How do I fix CVE-2021-48018?

Upgrade vyper to 0.2.15 or later.

## Is CVE-2021-48018 being exploited?

There is no known exploitation of CVE-2021-48018 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-48018 and fix it if it is affected.

What it is: CVE-2021-48018 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2021-48018 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected from 0.2.13; fixed in 0.2.15
- vyper (PyPI): affected from 0.2.13; fixed in 0.2.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-48018/ (Markdown: https://insights.sbomify.com/CVE-2021-48018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-48018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-48018
- OSV: https://osv.dev/vulnerability/CVE-2021-48018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-48018/
Summaries are generated and may contain mistakes; the official description above is the record.
