# CVE-2021-48019: Vyper before 0.2.9 Incorrect RETURNDATASIZE in create_forwarder_to Proxies


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-375m-5fvv-xq23, GHSA-q48v-45cg-432r

## What is CVE-2021-48019?

CVE-2021-48019 is a medium-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. 

### Official description

Vyper before 0.2.9 deploys forwarder proxies through the built-in create_forwarder_to function that report a fixed 4096-byte RETURNDATASIZE rather than the actual return data size. Calls through these proxies can yield corrupted data when a function returns more than 4096 bytes without return data sanitation, and fail strict return-size checks such as SafeERC20.safeTransfer.

Weakness: CWE-805 (Buffer Access with Incorrect Length Value)

## Which versions are affected by CVE-2021-48019?

2 open source packages ship an affected version, including vyper.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.2.9 |
| `vyper` | PyPI | All versions | 0.2.9 |

## How do I fix CVE-2021-48019?

Upgrade vyper to 0.2.9 or later.

## Is CVE-2021-48019 being exploited?

There is no known exploitation of CVE-2021-48019 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-48019 and fix it if it is affected.

What it is: CVE-2021-48019 is a medium-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2021-48019 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.2.9
- vyper (PyPI): affected all versions; fixed in 0.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-48019/ (Markdown: https://insights.sbomify.com/CVE-2021-48019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-48019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-48019
- OSV: https://osv.dev/vulnerability/CVE-2021-48019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-48019/
Summaries are generated and may contain mistakes; the official description above is the record.
