# CVE-2022-0085: Server-Side Request Forgery (SSRF) in dompdf/dompdf

> An attacker can exploit a Server-Side Request Forgery vulnerability in the dompdf library to access internal resources or bypass security controls.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-pf6p-25r2-fx45

## What is CVE-2022-0085?

CVE-2022-0085 is a low-severity server-side request forgery vulnerability in dompdf/dompdf, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Server-Side Request Forgery (SSRF) in GitHub repository dompdf/dompdf prior to 2.0.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-0085?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | All versions | 2.0.0 |
| `dompdf/dompdf` | Packagist | All versions | 2.0.0 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2022-0085?

Upgrade dompdf/dompdf to 2.0.0 or later.

## Is CVE-2022-0085 being exploited?

There is no known exploitation of CVE-2022-0085 in the wild and no public exploit code.

## Other vulnerabilities in dompdf/dompdf

- [CVE-2023-24813](https://insights.sbomify.com/CVE-2023-24813/): URI validation failure on SVG parsing. Bypass of CVE-2023-23924 (critical 10.0)
- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0085 and fix it if it is affected.

What it is: CVE-2022-0085 is a low-severity server-side request forgery vulnerability in dompdf/dompdf, published on 28 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0085 in the wild and no public exploit code.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected all versions; fixed in 2.0.0
- dompdf/dompdf (Packagist): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0085/ (Markdown: https://insights.sbomify.com/CVE-2022-0085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0085
- OSV: https://osv.dev/vulnerability/CVE-2022-0085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0085/
Summaries are generated and may contain mistakes; the official description above is the record.
