{"answers":{"affected":"2 open source packages ship an affected version, including @uppy/companion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0086 in the wild and no public exploit code.","fix":"Upgrade @uppy/companion to 3.1.5 or later.","what":"CVE-2022-0086 is a high-severity server-side request forgery vulnerability in transloadit/uppy, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0086 and fix it if it is affected.\n\nWhat it is: CVE-2022-0086 is a high-severity server-side request forgery vulnerability in transloadit/uppy, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0086 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @uppy/companion (npm): affected all versions; fixed in 3.1.5\n- @uppy/companion (npm): affected all versions; fixed in 3.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0086/ (Markdown: https://insights.sbomify.com/CVE-2022-0086/index.md)","id":"CVE-2022-0086","markdown":"https://insights.sbomify.com/CVE-2022-0086/index.md","name":"CVE-2022-0086","record":{"aliases":["GHSA-x8rq-rc7x-5fg5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript file uploader","requires_auth":"none","summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in the Uppy library to access internal resources or bypass security controls.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"uppy","vendor":"transloadit"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"uppy is vulnerable to Server-Side Request Forgery (SSRF)","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery (SSRF) in transloadit/uppy","id":"CVE-2022-0086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) - Reflected in keystonejs/keystone","id":"CVE-2022-0087"},"packages":[{"ecosystem":"npm","fixed":["3.1.5"],"introduced":["0"],"last_affected":[],"package":"@uppy/companion","purl":null,"source":"GHSA-x8rq-rc7x-5fg5"},{"ecosystem":"npm","fixed":["3.1.5"],"introduced":["0"],"last_affected":[],"package":"@uppy/companion","purl":"pkg:npm/%40uppy/companion","source":"GHSA-x8rq-rc7x-5fg5"}],"prev":{"headline":"Server-Side Request Forgery (SSRF) in dompdf/dompdf","id":"CVE-2022-0085"},"products":["transloadit/uppy"],"published":"2022-01-04","related":[{"cvss_score":7.5,"headline":"Server-Side Request Forgery in @uppy/companion","id":"CVE-2020-8205","kev_date_added":null,"published":"2020-07-20"},{"cvss_score":6.5,"headline":"Server-Side Request Forgery (SSRF) in transloadit/uppy","id":"CVE-2022-0528","kev_date_added":null,"published":"2022-03-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["transloadit"]},"summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in the Uppy library to access internal resources or bypass security controls.","url":"https://insights.sbomify.com/CVE-2022-0086/"}