# CVE-2022-0087: Cross-site Scripting (XSS) - Reflected in keystonejs/keystone

> Reflected Cross-Site Scripting in KeystoneJS allows attackers to inject malicious scripts into web pages viewed by other users.

- **Severity:** High 7.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jan 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hrgx-7j6v-xj82

## What is CVE-2022-0087?

CVE-2022-0087 is a high-severity cross-site scripting vulnerability in keystonejs/keystone, published on 11 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

keystone is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0087?

4 open source packages ship an affected version, including @keystone-6/auth and @keystone-next/auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@keystone-6/auth` | npm | All versions | 1.0.2 |
| `@keystone-6/auth` | npm | All versions | 1.0.2 |
| `@keystone-next/auth` | npm | All versions to 37.0.0 | None |
| `@keystone-next/auth` | npm | All versions to 37.0.0 | None |

Products: Keystonejs Keystone.

## How do I fix CVE-2022-0087?

Upgrade @keystone-6/auth to 1.0.2 or later.

## Is CVE-2022-0087 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0087 exists.

Public exploit code:

- Keystone 6 Login Page - Open Redirect and Cross-Site Scripting (nuclei): http/cves/2022/CVE-2022-0087.yaml

## Other vulnerabilities in keystonejs/keystone

- [CVE-2022-39382](https://insights.sbomify.com/CVE-2022-39382/): NODE_ENV in Keystone defaults to development with esbuild (critical 9.8)
- [CVE-2022-29354](https://insights.sbomify.com/CVE-2022-29354/): File upload in n/a (critical 9.8)
- [CVE-2022-39322](https://insights.sbomify.com/CVE-2022-39322/): @keystone-6/core vulnerable to field-level access-control bypass for multiselect field (critical 9.1)
- [CVE-2017-16570](https://insights.sbomify.com/CVE-2017-16570/): Cross-Site Request Forgery (CSRF) in keystone (high 8.8)
- [CVE-2017-15879](https://insights.sbomify.com/CVE-2017-15879/): Keystone is vulnerable to CSV injection (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0087 and fix it if it is affected.

What it is: CVE-2022-0087 is a high-severity cross-site scripting vulnerability in keystonejs/keystone, published on 11 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0087 exists.

Affected packages and fixed versions:
- @keystone-6/auth (npm): affected all versions; fixed in 1.0.2
- @keystone-6/auth (npm): affected all versions; fixed in 1.0.2
- @keystone-next/auth (npm): affected all versions up to 37.0.0; no fix listed
- @keystone-next/auth (npm): affected all versions up to 37.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0087/ (Markdown: https://insights.sbomify.com/CVE-2022-0087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0087
- OSV: https://osv.dev/vulnerability/CVE-2022-0087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0087/
Summaries are generated and may contain mistakes; the official description above is the record.
