CVE-2022-0123 Other in GitLab
GitLab fails to validate SSL certificates for external CI services, allowing attackers to perform Man-in-the-Middle attacks and intercept data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-0123?
CVE-2022-0123 is a medium-severity vulnerability in Gitlab Gitlab, published on 28 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered affecting GitLab versions prior to 14.4.5, between 14.5.0 and 14.5.3, and between 14.6.0 and 14.6.1. GitLab does not validate SSL certificates for some of external CI services which makes it possible to perform MitM attacks on connections to these external services.
Weakness: CWE-295
Which versions are affected by CVE-2022-0123?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 14.4.5, 14.5.3, 14.6.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-0123?
Upgrade gitlab to a fixed version for your release line: 14.4.5, 14.5.3 or 14.6.1.
Is CVE-2022-0123 being exploited?
There is no known exploitation of CVE-2022-0123 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-0123, GHSA-h2r9-r9v2-fvwp, UBUNTU-CVE-2022-0123.