# CVE-2022-0123: Other in GitLab

> GitLab fails to validate SSL certificates for external CI services, allowing attackers to perform Man-in-the-Middle attacks and intercept data.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-gitlab-2022-0123, GHSA-h2r9-r9v2-fvwp, UBUNTU-CVE-2022-0123

## What is CVE-2022-0123?

CVE-2022-0123 is a medium-severity vulnerability in Gitlab Gitlab, published on 28 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue has been discovered affecting GitLab versions prior to 14.4.5, between 14.5.0 and 14.5.3, and between 14.6.0 and 14.6.1. GitLab does not validate SSL certificates for some of external CI services which makes it possible to perform MitM attacks on connections to these external services.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-0123?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | All versions | 14.4.5, 14.5.3, 14.6.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2022-0123?

Upgrade gitlab to a fixed version for your release line: 14.4.5, 14.5.3 or 14.6.1.

## Is CVE-2022-0123 being exploited?

There is no known exploitation of CVE-2022-0123 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0123 and fix it if it is affected.

What it is: CVE-2022-0123 is a medium-severity vulnerability in Gitlab Gitlab, published on 28 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0123 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected all versions; fixed in 14.4.5, 14.5.3, 14.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0123/ (Markdown: https://insights.sbomify.com/CVE-2022-0123/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0123
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0123
- OSV: https://osv.dev/vulnerability/CVE-2022-0123

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0123/
Summaries are generated and may contain mistakes; the official description above is the record.
