# CVE-2022-0144: Improper Privilege Management in shelljs/shelljs

> Attackers can exploit improper privilege management in the shelljs library to escalate privileges within the application context.

- **Severity:** High 7.1 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2022
- **Updated:** 8 Oct 2026
- **Also known as:** CLSA-2026-1775089657, CLSA-2026-1775089658, CLSA-2026-1784682961, CLSA-2026-1785291224, DEBIAN-CVE-2022-0144, GHSA-4rq4-32rv-6wp6, ROOT-APP-NPM-CVE-2022-0144, UBUNTU-CVE-2022-0144

## What is CVE-2022-0144?

CVE-2022-0144 is a high-severity vulnerability in shelljs/shelljs, published on 11 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

shelljs is vulnerable to Improper Privilege Management

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-0144?

2 open source packages ship an affected version, including shelljs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shelljs` | npm | All versions | 0.8.5 |
| `shelljs` | npm | All versions | 0.8.5 |

Products: Shelljs Project Shelljs.

## How do I fix CVE-2022-0144?

Upgrade shelljs to 0.8.5 or later.

## Is CVE-2022-0144 being exploited?

There is no known exploitation of CVE-2022-0144 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0144 and fix it if it is affected.

What it is: CVE-2022-0144 is a high-severity vulnerability in shelljs/shelljs, published on 11 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0144 in the wild and no public exploit code.

Affected packages and fixed versions:
- shelljs (npm): affected all versions; fixed in 0.8.5
- shelljs (npm): affected all versions; fixed in 0.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0144/ (Markdown: https://insights.sbomify.com/CVE-2022-0144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0144
- OSV: https://osv.dev/vulnerability/CVE-2022-0144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0144/
Summaries are generated and may contain mistakes; the official description above is the record.
