CVE-2022-0151 Denial of service in GitLab

Medium 6.5 Published Updated

Attackers can cause a Denial of Service in GitLab by exploiting improper handling of package deletion requests.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-0151?

CVE-2022-0151 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 18 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 12.10 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was not correctly handling requests to delete existing packages which could result in a Denial of Service under specific conditions.

Which versions are affected by CVE-2022-0151?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.10.014.4.5, 14.5.3, 14.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-0151?

Upgrade gitlab to a fixed version for your release line: 14.4.5, 14.5.3 or 14.6.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-0151 being exploited?

There is no known exploitation of CVE-2022-0151 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-0151, GHSA-c9xg-h9c4-4vv6, UBUNTU-CVE-2022-0151.

Is CVE-2022-0151 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free