CVE-2022-0152 Missing authorization in GitLab

Medium 6.5 Published Updated

Attackers can access unauthorized fields via the GraphQL API, potentially exposing sensitive data in GitLab instances.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-0152?

CVE-2022-0152 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 18 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 13.10 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was vulnerable to unauthorized access to some particular fields through the GraphQL API.

Weakness: CWE-862

Which versions are affected by CVE-2022-0152?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.10.014.4.5, 14.5.3, 14.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-0152?

Upgrade gitlab to a fixed version for your release line: 14.4.5, 14.5.3 or 14.6.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-0152 being exploited?

There is no known exploitation of CVE-2022-0152 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-0152, GHSA-wggh-9jhq-9h7x, UBUNTU-CVE-2022-0152.

Is CVE-2022-0152 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free