CVE-2022-0154 Cross-site request forgery in GitLab

High 7.5 Published Updated

A CSRF vulnerability in GitLab allows attackers to import GitHub projects into other users' accounts, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-0154?

CVE-2022-0154 is a high-severity vulnerability in Gitlab Gitlab, published on 18 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 7.7 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was vulnerable to a Cross-Site Request Forgery attack that allows a malicious user to have their GitHub project imported on another GitLab user account.

Weakness: CWE-352

Which versions are affected by CVE-2022-0154?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.7.014.4.5, 14.5.3, 14.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-0154?

Upgrade gitlab to a fixed version for your release line: 14.4.5, 14.5.3 or 14.6.2.

Is CVE-2022-0154 being exploited?

There is no known exploitation of CVE-2022-0154 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-0154, GHSA-c8m7-c9rp-w2g3, UBUNTU-CVE-2022-0154.

Is CVE-2022-0154 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free