CVE-2022-0167 Information disclosure in GitLab

Low 3.1 Published Updated

GitLab failed to disable autocomplete on sensitive fields, allowing attackers to retrieve sensitive information under certain conditions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-0167?

CVE-2022-0167 is a low-severity vulnerability in Gitlab Gitlab, published on 1 Jul 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 14.0 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was not disabling the Autocomplete attribute of fields related to sensitive information making it possible to be retrieved under certain conditions.

Weakness: CWE-79

Which versions are affected by CVE-2022-0167?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.0.014.4.5, 14.5.3, 14.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-0167?

Upgrade gitlab to a fixed version for your release line: 14.4.5, 14.5.3 or 14.6.2.

Is CVE-2022-0167 being exploited?

There is no known exploitation of CVE-2022-0167 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-0167, GHSA-gfj2-5hv5-w3x2.

Is CVE-2022-0167 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free