{"answers":{"affected":"3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0174 in the wild and no public exploit code.","fix":"Upgrade dolibarr/dolibarr to 15.0.0 or later.","what":"CVE-2022-0174 is a medium-severity vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 10 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0174 and fix it if it is affected.\n\nWhat it is: CVE-2022-0174 is a medium-severity vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 10 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0174 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 15.0.0\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 15.0.0\n- dolibarr (Bitnami): affected all versions; fixed in 15.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0174/ (Markdown: https://insights.sbomify.com/CVE-2022-0174/index.md)","id":"CVE-2022-0174","markdown":"https://insights.sbomify.com/CVE-2022-0174/index.md","name":"CVE-2022-0174","record":{"aliases":["BIT-dolibarr-2022-0174","GHSA-8qvx-f5gf-g43v","UBUNTU-CVE-2022-0174"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"low_privilege","summary":"Attackers can exploit improper input quantity validation in Dolibarr, potentially causing service disruption or unexpected behavior.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"dolibarr_erp\\/crm","vendor":"dolibarr"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"Improper Validation of Specified Quantity in Input vulnerability in dolibarr dolibarr/dolibarr.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Validation of Specified Quantity in Input in dolibarr/dolibarr","id":"CVE-2022-0174","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"dolibarr:dolibarr_erp\\/crm","products":["dolibarr:dolibarr_erp\\/crm"],"type":"other","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Information disclosure in virglrenderer","id":"CVE-2022-0175"},"packages":[{"ecosystem":"Bitnami","fixed":["15.0.0"],"introduced":["0"],"last_affected":[],"package":"dolibarr","purl":"pkg:bitnami/dolibarr","source":"BIT-dolibarr-2022-0174"},{"ecosystem":"Packagist","fixed":["15.0.0"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-8qvx-f5gf-g43v"},{"ecosystem":"Packagist","fixed":["15.0.0"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-8qvx-f5gf-g43v"}],"prev":{"headline":"Out-of-bounds Read in radareorg/radare2","id":"CVE-2022-0173"},"products":["dolibarr/dolibarr"],"published":"2022-01-10","related":[{"cvss_score":9.8,"headline":"Dolibarr vulnerable to privilege escalation","id":"CVE-2022-43138","kev_date_added":null,"published":"2022-11-17"},{"cvss_score":9.8,"headline":"Dolibarr vulnerable to Eval Injection","id":"CVE-2022-40871","kev_date_added":null,"published":"2022-10-12"},{"cvss_score":9.8,"headline":"Dolibarr remote PHP code execution","id":"CVE-2021-33816","kev_date_added":null,"published":"2021-11-10"},{"cvss_score":9.8,"headline":"Dolibarr Improper Restriction of Excessive Authentication Attempts","id":"CVE-2020-7995","kev_date_added":null,"published":"2020-01-26"},{"cvss_score":9.8,"headline":"SQL injection in dolibarr","id":"CVE-2013-2091","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Command injection in dolibarr","id":"CVE-2013-2093","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in product/card.php","id":"CVE-2018-13447","kev_date_added":null,"published":"2018-07-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["dolibarr"]},"summary":"Attackers can exploit improper input quantity validation in Dolibarr, potentially causing service disruption or unexpected behavior.","url":"https://insights.sbomify.com/CVE-2022-0174/"}