# CVE-2022-0219: Improper Restriction of XML External Entity Reference in skylot/jadx

> An attacker can exploit XML External Entity vulnerabilities in the jadx decompiler to read sensitive files or cause denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jan 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-r8j4-96mx-rjcc

## What is CVE-2022-0219?

CVE-2022-0219 is a medium-severity vulnerability in skylot/jadx, published on 20 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper Restriction of XML External Entity Reference in GitHub repository skylot/jadx prior to 1.3.2.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-0219?

2 open source packages ship an affected version, including io.github.skylot:jadx-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.github.skylot:jadx-core` | Maven | All versions | 1.3.2 |
| `io.github.skylot:jadx-core` | Maven | All versions | 1.3.2 |

Products: Jadx Project Jadx.

## How do I fix CVE-2022-0219?

Upgrade io.github.skylot:jadx-core to 1.3.2 or later.

## Is CVE-2022-0219 being exploited?

There is no known exploitation of CVE-2022-0219 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Haxatron/CVE-2022-0219 (github_poc): https://github.com/Haxatron/CVE-2022-0219

## Other vulnerabilities in skylot/jadx

- [CVE-2026-42447](https://insights.sbomify.com/CVE-2026-42447/): jadx: HTML Injection in Summary panel (low 3.6)
- [CVE-2022-39259](https://insights.sbomify.com/CVE-2022-39259/): Jadx-gui subject to Denial of Service via Swing HTML rendering (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0219 and fix it if it is affected.

What it is: CVE-2022-0219 is a medium-severity vulnerability in skylot/jadx, published on 20 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0219 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.github.skylot:jadx-core (Maven): affected all versions; fixed in 1.3.2
- io.github.skylot:jadx-core (Maven): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0219/ (Markdown: https://insights.sbomify.com/CVE-2022-0219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0219
- OSV: https://osv.dev/vulnerability/CVE-2022-0219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0219/
Summaries are generated and may contain mistakes; the official description above is the record.
