# CVE-2022-0224: SQL Injection in dolibarr/dolibarr

> Attackers can execute arbitrary SQL commands in Dolibarr, potentially reading or modifying database contents.

- **Severity:** High 8.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2022
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-dolibarr-2022-0224, GHSA-j545-frh3-r9gq, UBUNTU-CVE-2022-0224

## What is CVE-2022-0224?

CVE-2022-0224 is a high-severity SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 14 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

dolibarr is vulnerable to Improper Neutralization of Special Elements used in an SQL Command

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-0224?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions to 14.0.5 | None |
| `dolibarr/dolibarr` | Packagist | All versions to 14.0.5 | None |
| `dolibarr` | Bitnami | All versions | 15.0.0 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2022-0224?

Upgrade to a fixed version.

## Is CVE-2022-0224 being exploited?

There is no known exploitation of CVE-2022-0224 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0224 and fix it if it is affected.

What it is: CVE-2022-0224 is a high-severity SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 14 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0224 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions up to 14.0.5; no fix listed
- dolibarr/dolibarr (Packagist): affected all versions up to 14.0.5; no fix listed
- dolibarr (Bitnami): affected all versions; fixed in 15.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0224/ (Markdown: https://insights.sbomify.com/CVE-2022-0224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0224
- OSV: https://osv.dev/vulnerability/CVE-2022-0224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0224/
Summaries are generated and may contain mistakes; the official description above is the record.
