# CVE-2022-0225: Stored Cross-Site Scripting (XSS) in Keycloak via groups dropdown

> A privileged attacker can inject malicious scripts via group names in Keycloak, enabling stored XSS attacks against other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-755v-r4x4-qf7m, GHSA-fqc7-5xxc-ph7r

## What is CVE-2022-0225?

CVE-2022-0225 is a medium-severity cross-site scripting vulnerability in Redhat Keycloak, published on 26 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Keycloak. This flaw allows a privileged attacker to use the malicious payload as the group name while creating a new group from the admin console, leading to a stored Cross-site scripting (XSS) attack.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0225?

4 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions to 16.1.0 | None |
| `org.keycloak:keycloak-core` | Maven | All versions to 16.1.0 | None |
| `org.keycloak:keycloak-core` | Maven | All versions | 20.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 20.0.0 |

Products: Redhat Keycloak, Redhat Single Sign-On.

## How do I fix CVE-2022-0225?

Upgrade org.keycloak:keycloak-core to 20.0.0 or later.

## Is CVE-2022-0225 being exploited?

There is no known exploitation of CVE-2022-0225 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0225 and fix it if it is affected.

What it is: CVE-2022-0225 is a medium-severity cross-site scripting vulnerability in Redhat Keycloak, published on 26 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0225 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions up to 16.1.0; no fix listed
- org.keycloak:keycloak-core (Maven): affected all versions up to 16.1.0; no fix listed
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 20.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 20.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0225/ (Markdown: https://insights.sbomify.com/CVE-2022-0225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0225
- OSV: https://osv.dev/vulnerability/CVE-2022-0225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0225/
Summaries are generated and may contain mistakes; the official description above is the record.
