{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/framework.","exploited":"There is no known exploitation of CVE-2022-0227 in the wild and no public exploit code.","fix":"Upgrade silverstripe/framework to 4.10.1 or later.","what":"CVE-2022-0227 is a vulnerability in silverstripe/framework, published on 4 Feb 2022."},"fix_prompt":"Check this codebase for CVE-2022-0227 and fix it if it is affected.\n\nWhat it is: CVE-2022-0227 is a vulnerability in silverstripe/framework, published on 4 Feb 2022. \nExploitation: There is no known exploitation of CVE-2022-0227 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/framework (Packagist): affected all versions; fixed in 4.10.1\n- silverstripe/framework (Packagist): affected all versions; fixed in 4.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0227/ (Markdown: https://insights.sbomify.com/CVE-2022-0227/index.md)","id":"CVE-2022-0227","markdown":"https://insights.sbomify.com/CVE-2022-0227/index.md","name":"CVE-2022-0227","record":{"aliases":["GHSA-32m2-9f76-4gv8"],"analysis":null,"analysis_generated_by":null,"assigner":"@huntrdev","cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"DO NOT USE THIS CANDIDATE NUMBER. Reason: This CVE has been rejected as it was incorrectly assigned. All references and descriptions in this candidate have been removed to prevent accidental usage","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Business Logic Errors in SilverStripe Framework","id":"CVE-2022-0227","indexable":false,"kev":null,"kind":"cve_rejected","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2022"},"n_packages":2,"n_references":0,"next":{"headline":"Popup Builder \u003c 4.0.7 - Admin+ SQL Injection","id":"CVE-2022-0228"},"packages":[{"ecosystem":"Packagist","fixed":["4.10.1"],"introduced":["0"],"last_affected":[],"package":"silverstripe/framework","purl":null,"source":"GHSA-32m2-9f76-4gv8"},{"ecosystem":"Packagist","fixed":["4.10.1"],"introduced":["0"],"last_affected":[],"package":"silverstripe/framework","purl":"pkg:composer/silverstripe/framework","source":"GHSA-32m2-9f76-4gv8"}],"prev":{"headline":"Cross-Site Request Forgery (CSRF) in livehelperchat/livehelperchat","id":"CVE-2022-0226"},"products":[],"published":"2022-02-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"REJECTED","updated":"2022-04-04","vendors":[]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-0227/"}