# CVE-2022-0231: Cross-Site Request Forgery (CSRF) in livehelperchat/livehelperchat

> Attackers can trick authenticated users into performing unwanted actions in Live Helper Chat via Cross-Site Request Forgery.

- **Severity:** Medium 5.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2022
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-livehelperchat-2022-0231, GHSA-8m28-w6xg-35hw

## What is CVE-2022-0231?

CVE-2022-0231 is a medium-severity vulnerability in livehelperchat/livehelperchat, published on 14 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

livehelperchat is vulnerable to Cross-Site Request Forgery (CSRF)

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-0231?

3 open source packages ship an affected version, including remdex/livehelperchat and livehelperchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remdex/livehelperchat` | Packagist | All versions | 3.92 |
| `remdex/livehelperchat` | Packagist | All versions | 3.92 |
| `livehelperchat` | Bitnami | All versions | 3.91.0 |

Products: Livehelperchat Live Helper Chat.

## How do I fix CVE-2022-0231?

Upgrade remdex/livehelperchat to 3.92 or later.

## Is CVE-2022-0231 being exploited?

There is no known exploitation of CVE-2022-0231 in the wild and no public exploit code.

## Other vulnerabilities in livehelperchat/livehelperchat

- [CVE-2024-27516](https://insights.sbomify.com/CVE-2024-27516/): livehelperchat Server-Side Template Injection (critical 9.8)
- [CVE-2022-0935](https://insights.sbomify.com/CVE-2022-0935/): Host Header injection in password Reset in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1234](https://insights.sbomify.com/CVE-2022-1234/): XSS in livehelperchat in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1191](https://insights.sbomify.com/CVE-2022-1191/): SSRF on index.php/cobrowse/proxycss/ in livehelperchat/livehelperchat (high 8.7)
- [CVE-2022-1213](https://insights.sbomify.com/CVE-2022-1213/): SSRF filter bypass port 80, 433 in livehelperchat/livehelperchat (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0231 and fix it if it is affected.

What it is: CVE-2022-0231 is a medium-severity vulnerability in livehelperchat/livehelperchat, published on 14 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0231 in the wild and no public exploit code.

Affected packages and fixed versions:
- remdex/livehelperchat (Packagist): affected all versions; fixed in 3.92
- remdex/livehelperchat (Packagist): affected all versions; fixed in 3.92
- livehelperchat (Bitnami): affected all versions; fixed in 3.91.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0231/ (Markdown: https://insights.sbomify.com/CVE-2022-0231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0231
- OSV: https://osv.dev/vulnerability/CVE-2022-0231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0231/
Summaries are generated and may contain mistakes; the official description above is the record.
