{"answers":{"affected":"2 open source packages ship an affected version, including edu.stanford.nlp:stanford-corenlp. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0239 exists.","fix":"Upgrade edu.stanford.nlp:stanford-corenlp to 4.4.0 or later.","what":"CVE-2022-0239 is a medium-severity vulnerability in stanfordnlp/corenlp, published on 17 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0239 and fix it if it is affected.\n\nWhat it is: CVE-2022-0239 is a medium-severity vulnerability in stanfordnlp/corenlp, published on 17 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-0239 exists.\n\nAffected packages and fixed versions:\n- edu.stanford.nlp:stanford-corenlp (Maven): affected all versions; fixed in 4.4.0\n- edu.stanford.nlp:stanford-corenlp (Maven): affected all versions; fixed in 4.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0239/ (Markdown: https://insights.sbomify.com/CVE-2022-0239/index.md)","id":"CVE-2022-0239","markdown":"https://insights.sbomify.com/CVE-2022-0239/index.md","name":"CVE-2022-0239","record":{"aliases":["GHSA-75vw-3m5v-fprh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Stanford CoreNLP library","requires_auth":"none","summary":"Attackers can exploit XML External Entity vulnerabilities in Stanford CoreNLP to read sensitive files or cause denial of service.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"corenlp","vendor":"stanford"}],"cvss":{"score":4.7,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"corenlp is vulnerable to Improper Restriction of XML External Entity Reference","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2022-0239","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"NULL Pointer Dereference in mruby/mruby","id":"CVE-2022-0240"},"packages":[{"ecosystem":"Maven","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"edu.stanford.nlp:stanford-corenlp","purl":null,"source":"GHSA-75vw-3m5v-fprh"},{"ecosystem":"Maven","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"edu.stanford.nlp:stanford-corenlp","purl":"pkg:maven/edu.stanford.nlp/stanford-corenlp","source":"GHSA-75vw-3m5v-fprh"}],"prev":{"headline":"Cross-Site Request Forgery (CSRF) in phoronix-test-suite/phoronix-test-suite","id":"CVE-2022-0238"},"products":["stanfordnlp/corenlp"],"published":"2022-01-17","related":[{"cvss_score":9.8,"headline":"Access Control vulnerability within CoreNLP","id":"CVE-2021-44550","kev_date_added":null,"published":"2022-02-23"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2021-3878","kev_date_added":null,"published":"2021-10-15"},{"cvss_score":8.6,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2021-3869","kev_date_added":null,"published":"2021-10-19"},{"cvss_score":6.1,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2022-0198","kev_date_added":null,"published":"2022-01-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-23","vendors":["stanfordnlp"]},"summary":"Attackers can exploit XML External Entity vulnerabilities in Stanford CoreNLP to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2022-0239/"}