CVE-2022-0254 Zero Spam < 5.2.11 - Admin+ SQL Injection

Critical 9.8 Published Updated

An authenticated admin can exploit SQL injection in the Zero Spam plugin to read or modify database contents.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-0254?

CVE-2022-0254 is a critical SQL injection vulnerability in Unknown WordPress Zero Spam, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The WordPress Zero Spam WordPress plugin before 5.2.11 does not properly sanitise and escape the order and orderby parameters before using them in a SQL statement in the admin dashboard, leading to a SQL injection

Weakness: CWE-89

Which versions are affected by CVE-2022-0254?

2 open source packages ship an affected version, including bmarshall511/wordpress_zero_spam. It affects 1 product.

PackageAffectedFixed in
bmarshall511/wordpress_zero_spam PackagistAll versions5.2.13
bmarshall511/wordpress_zero_spam PackagistAll versions5.2.13

Products include Highfivery Zero-Spam.

How do I fix CVE-2022-0254?

Upgrade bmarshall511/wordpress_zero_spam to 5.2.13 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2022-0254 being exploited?

There is no known exploitation of CVE-2022-0254 in the wild and no public exploit code.

Sources

Also known as GHSA-pq2f-3fg3-rw99.

Is CVE-2022-0254 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free