{"answers":{"affected":"2 open source packages ship an affected version, including bmarshall511/wordpress_zero_spam. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0254 in the wild and no public exploit code.","fix":"Upgrade bmarshall511/wordpress_zero_spam to 5.2.13 or later.","what":"CVE-2022-0254 is a critical SQL injection vulnerability in Unknown WordPress Zero Spam, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0254 and fix it if it is affected.\n\nWhat it is: CVE-2022-0254 is a critical SQL injection vulnerability in Unknown WordPress Zero Spam, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0254 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bmarshall511/wordpress_zero_spam (Packagist): affected all versions; fixed in 5.2.13\n- bmarshall511/wordpress_zero_spam (Packagist): affected all versions; fixed in 5.2.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0254/ (Markdown: https://insights.sbomify.com/CVE-2022-0254/index.md)","id":"CVE-2022-0254","markdown":"https://insights.sbomify.com/CVE-2022-0254/index.md","name":"CVE-2022-0254","record":{"aliases":["GHSA-pq2f-3fg3-rw99"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"An authenticated admin can exploit SQL injection in the Zero Spam plugin to read or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[{"product":"zero-spam","vendor":"highfivery"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"The WordPress Zero Spam WordPress plugin before 5.2.11 does not properly sanitise and escape the order and orderby parameters before using them in a SQL statement in the admin dashboard, leading to a SQL injection","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zero Spam \u003c 5.2.11 - Admin+ SQL Injection","id":"CVE-2022-0254","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Database Backup for WordPress \u003c 2.5.1 - Admin+ SQL Injection","id":"CVE-2022-0255"},"packages":[{"ecosystem":"Packagist","fixed":["5.2.13"],"introduced":["0"],"last_affected":[],"package":"bmarshall511/wordpress_zero_spam","purl":null,"source":"GHSA-pq2f-3fg3-rw99"},{"ecosystem":"Packagist","fixed":["5.2.13"],"introduced":["0"],"last_affected":[],"package":"bmarshall511/wordpress_zero_spam","purl":"pkg:composer/bmarshall511/wordpress_zero_spam","source":"GHSA-pq2f-3fg3-rw99"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in livehelperchat/livehelperchat","id":"CVE-2022-0253"},"products":["WordPress Zero Spam"],"published":"2022-03-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["Unknown"]},"summary":"An authenticated admin can exploit SQL injection in the Zero Spam plugin to read or modify database contents.","url":"https://insights.sbomify.com/CVE-2022-0254/"}