# CVE-2022-0274: Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore

> Stored Cross-Site Scripting in OrchardCore allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-r8hp-5m7c-jhv4

## What is CVE-2022-0274?

CVE-2022-0274 is a medium-severity cross-site scripting vulnerability in orchardcms/orchardcore, published on 19 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - Stored in NuGet OrchardCore.Application.Cms.Targets prior to 1.2.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0274?

2 open source packages ship an affected version, including OrchardCore.Application.Cms.Targets. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OrchardCore.Application.Cms.Targets` | NuGet | All versions | 1.2.2 |
| `OrchardCore.Application.Cms.Targets` | NuGet | All versions | 1.2.2 |

Products: Orchardcore Orchardcore.

## How do I fix CVE-2022-0274?

Upgrade OrchardCore.Application.Cms.Targets to 1.2.2 or later.

## Is CVE-2022-0274 being exploited?

There is no known exploitation of CVE-2022-0274 in the wild and no public exploit code.

## Other vulnerabilities in orchardcms/orchardcore

- [CVE-2022-0243](https://insights.sbomify.com/CVE-2022-0243/): Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore (high 7.4)
- [CVE-2022-0159](https://insights.sbomify.com/CVE-2022-0159/): Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore (high 7.4)
- [CVE-2022-0821](https://insights.sbomify.com/CVE-2022-0821/): Improper Authorization in orchardcms/orchardcore (high 7.1)
- [CVE-2022-32173](https://insights.sbomify.com/CVE-2022-32173/): OrchardCore - HTML Injection (medium 5.4)
- [CVE-2022-0822](https://insights.sbomify.com/CVE-2022-0822/): Cross-site Scripting (XSS) - Reflected in orchardcms/orchardcore (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0274 and fix it if it is affected.

What it is: CVE-2022-0274 is a medium-severity cross-site scripting vulnerability in orchardcms/orchardcore, published on 19 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-0274 in the wild and no public exploit code.

Affected packages and fixed versions:
- OrchardCore.Application.Cms.Targets (NuGet): affected all versions; fixed in 1.2.2
- OrchardCore.Application.Cms.Targets (NuGet): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0274/ (Markdown: https://insights.sbomify.com/CVE-2022-0274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0274
- OSV: https://osv.dev/vulnerability/CVE-2022-0274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0274/
Summaries are generated and may contain mistakes; the official description above is the record.
