{"answers":{"affected":"2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0277 in the wild and no public exploit code.","fix":"Upgrade microweber/microweber to 1.2.11 or later.","what":"CVE-2022-0277 is a medium-severity missing authorization vulnerability in Microweber Microweber, published on 20 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0277 and fix it if it is affected.\n\nWhat it is: CVE-2022-0277 is a medium-severity missing authorization vulnerability in Microweber Microweber, published on 20 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- microweber/microweber (Packagist): affected all versions; fixed in 1.2.11\n- microweber/microweber (Packagist): affected all versions; fixed in 1.2.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0277/ (Markdown: https://insights.sbomify.com/CVE-2022-0277/index.md)","id":"CVE-2022-0277","markdown":"https://insights.sbomify.com/CVE-2022-0277/index.md","name":"CVE-2022-0277","record":{"aliases":["GHSA-vcgf-vmpc-ph79"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Microweber CMS","requires_auth":"low_privilege","summary":"Attackers can exploit incorrect permission assignments to access critical resources, potentially leading to privilege escalation or data modification in Microweber.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"microweber","vendor":"microweber"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Incorrect Permission Assignment for Critical Resource in Packagist microweber/microweber prior to 1.2.11.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Permission Assignment for Critical Resource in microweber/microweber","id":"CVE-2022-0277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"microweber:microweber","products":["microweber:microweber"],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) - Stored in microweber/microweber","id":"CVE-2022-0278"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"microweber/microweber","purl":null,"source":"GHSA-vcgf-vmpc-ph79"},{"ecosystem":"Packagist","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"microweber/microweber","purl":"pkg:composer/microweber/microweber","source":"GHSA-vcgf-vmpc-ph79"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore","id":"CVE-2022-0274"},"products":["microweber/microweber"],"published":"2022-01-20","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in microweber/microweber","id":"CVE-2022-0558","kev_date_added":null,"published":"2022-02-10"},{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2020-23138","kev_date_added":null,"published":"2020-11-09"},{"cvss_score":9.4,"headline":"Business Logic Errors in microweber/microweber","id":"CVE-2022-0688","kev_date_added":null,"published":"2022-02-20"},{"cvss_score":9.4,"headline":"Generation of Error Message Containing Sensitive Information in microweber/microweber","id":"CVE-2022-0660","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":9.1,"headline":"Integer Overflow or Wraparound in microweber/microweber","id":"CVE-2022-0913","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":9.1,"headline":"Insecure Storage of Sensitive Information in microweber/microweber","id":"CVE-2022-0724","kev_date_added":null,"published":"2022-02-23"},{"cvss_score":8.8,"headline":"Microweber file upload vulnerability","id":"CVE-2023-49052","kev_date_added":null,"published":"2023-11-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["microweber"]},"summary":"Attackers can exploit incorrect permission assignments to access critical resources, potentially leading to privilege escalation or data modification in Microweber.","url":"https://insights.sbomify.com/CVE-2022-0277/"}