# CVE-2022-0315: Insecure Temporary File in horovod/horovod

> An insecure temporary file vulnerability in Horovod allows attackers to read or modify sensitive data during execution.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-47wv-vhj2-g66m, PYSEC-2022-175

## What is CVE-2022-0315?

CVE-2022-0315 is a high-severity vulnerability in horovod/horovod, published on 24 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insecure Temporary File in GitHub repository horovod/horovod prior to 0.24.0.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-377 (DEPRECATED: Insecure Temporary File)

## Which versions are affected by CVE-2022-0315?

3 open source packages ship an affected version, including horovod. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `horovod` | PyPI | All versions | 0.24.0 |
| `horovod` | PyPI | All versions | 0.24.0 |
| `horovod` | PyPI | All versions | 0.24.0 |

Products: Horovod Horovod.

## How do I fix CVE-2022-0315?

Upgrade horovod to 0.24.0 or later.

## Is CVE-2022-0315 being exploited?

There is no known exploitation of CVE-2022-0315 in the wild and no public exploit code.

## Other vulnerabilities in horovod/horovod

- [CVE-2024-10190](https://insights.sbomify.com/CVE-2024-10190/): Unauthenticated Remote Code Execution in ElasticRendezvousHandler in horovod/horovod (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0315 and fix it if it is affected.

What it is: CVE-2022-0315 is a high-severity vulnerability in horovod/horovod, published on 24 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0315 in the wild and no public exploit code.

Affected packages and fixed versions:
- horovod (PyPI): affected all versions; fixed in 0.24.0
- horovod (PyPI): affected all versions; fixed in 0.24.0
- horovod (PyPI): affected all versions; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0315/ (Markdown: https://insights.sbomify.com/CVE-2022-0315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0315
- OSV: https://osv.dev/vulnerability/CVE-2022-0315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0315/
Summaries are generated and may contain mistakes; the official description above is the record.
