CVE-2022-0323 Improper Neutralization of Special Elements Used in a Template Engine in bobthecow/mustache.php
Medium 5.3
Published
Updated
Check this codebase for CVE-2022-0323 and fix it if it is affected.
What it is: CVE-2022-0323 is a medium-severity vulnerability in bobthecow/mustache.php, published on 21 Jan 2022.
Exploitation: There is no known exploitation of CVE-2022-0323 in the wild and no public exploit code.
Affected packages and fixed versions:
- mustache/mustache (Packagist): affected from 2.0.0; fixed in 2.14.1
- mustache/mustache (Packagist): affected from 2.0.0; fixed in 2.14.1
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2022-0323/ (Markdown: https://insights.sbomify.com/CVE-2022-0323/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2022-0323?
CVE-2022-0323 is a medium-severity vulnerability in bobthecow/mustache.php, published on 21 Jan 2022.
Official description
Improper Neutralization of Special Elements Used in a Template Engine in Packagist mustache/mustache prior to 2.14.1.
Which versions are affected by CVE-2022-0323?
2 open source packages ship an affected version, including mustache/mustache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mustache/mustache Packagist | From 2.0.0 | 2.14.1 |
mustache/mustache Packagist | From 2.0.0 | 2.14.1 |
Products include Mustache Project Mustache.
How do I fix CVE-2022-0323?
Upgrade mustache/mustache to 2.14.1 or later.
Is CVE-2022-0323 being exploited?
There is no known exploitation of CVE-2022-0323 in the wild and no public exploit code.
Sources
Also known as GHSA-4rmr-c2jx-vx27, UBUNTU-CVE-2022-0323.