{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0332 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to 3.11.5 or later.","what":"CVE-2022-0332 is a critical SQL injection vulnerability in Moodle Moodle, published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0332 and fix it if it is affected.\n\nWhat it is: CVE-2022-0332 is a critical SQL injection vulnerability in Moodle Moodle, published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0332 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.5\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.5\n- moodle (Bitnami): affected from 3.11.0; fixed in 3.11.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0332/ (Markdown: https://insights.sbomify.com/CVE-2022-0332/index.md)","id":"CVE-2022-0332","markdown":"https://insights.sbomify.com/CVE-2022-0332/index.md","name":"CVE-2022-0332","record":{"aliases":["BIT-moodle-2022-0332","GHSA-6jhm-4vmx-mr76","UBUNTU-CVE-2022-0332"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"An SQL injection vulnerability in Moodle's h5p activity web service allows attackers to read or modify user attempt data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A flaw was found in Moodle in versions 3.11 to 3.11.4. An SQL injection risk was identified in the h5p activity web service responsible for fetching user attempt data.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":1,"first_seen":"2022-01-25","github_poc":1,"max_poc_stars":46,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-01-25T23:58:17Z","kind":"github_poc","ref":"https://github.com/numanturle/CVE-2022-0332","stars":46,"title":null},{"date":"2022-02-02","kind":"exploitdb","ref":"50700","stars":null,"title":"Moodle 3.11.4  - SQL Injection"}],"tier":"poc_unverified"},"has_fix":true,"headline":"SQL injection in Moodle","id":"CVE-2022-0332","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"sql_injection","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Insufficient user authorization in Moodle","id":"CVE-2022-0333"},"packages":[{"ecosystem":"Bitnami","fixed":["3.11.5"],"introduced":["3.11.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2022-0332"},{"ecosystem":"Packagist","fixed":["3.11.5"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-6jhm-4vmx-mr76"},{"ecosystem":"Packagist","fixed":["3.11.5"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-6jhm-4vmx-mr76"}],"prev":{"headline":"Information disclosure in Sophos Firewall","id":"CVE-2022-0331"},"products":["moodle"],"published":"2022-01-25","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An SQL injection vulnerability in Moodle's h5p activity web service allows attackers to read or modify user attempt data.","url":"https://insights.sbomify.com/CVE-2022-0332/"}