CVE-2022-0333 Insufficient user authorization in Moodle
Managers can improperly access or modify user-level calendar events due to insufficient permission checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-0333?
CVE-2022-0333 is a low-severity missing authorization vulnerability in Moodle Moodle, published on 25 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.
Weakness: CWE-863
Which versions are affected by CVE-2022-0333?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.11 | 3.11.5 |
moodle/moodle Packagist | From 3.11 | 3.11.5 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
1 more packages
moodle Bitnami | All versions | 3.8.10, 3.9.12, 3.10.9, 3.11.5 |
Products include Moodle Moodle.
How do I fix CVE-2022-0333?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.5 or 3.9.11.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-0333 being exploited?
There is no known exploitation of CVE-2022-0333 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2022-0333, GHSA-m434-m5pv-p35w, UBUNTU-CVE-2022-0333.