{"answers":{"affected":"7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0333 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.5 or 3.9.11.","what":"CVE-2022-0333 is a low-severity missing authorization vulnerability in Moodle Moodle, published on 25 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0333 and fix it if it is affected.\n\nWhat it is: CVE-2022-0333 is a low-severity missing authorization vulnerability in Moodle Moodle, published on 25 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0333 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.8\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.8\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.5\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.5\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.11\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.11\n- moodle (Bitnami): affected all versions; fixed in 3.8.10, 3.9.12, 3.10.9, 3.11.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0333/ (Markdown: https://insights.sbomify.com/CVE-2022-0333/index.md)","id":"CVE-2022-0333","markdown":"https://insights.sbomify.com/CVE-2022-0333/index.md","name":"CVE-2022-0333","record":{"aliases":["BIT-moodle-2022-0333","GHSA-m434-m5pv-p35w","UBUNTU-CVE-2022-0333"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"high_privilege","summary":"Managers can improperly access or modify user-level calendar events due to insufficient permission checks in Moodle.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":3.8,"severity":"low","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient user authorization in Moodle","id":"CVE-2022-0333","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"missing_authorization","year":"2022"},"n_packages":7,"n_references":2,"next":{"headline":"Insufficient user authorization in Moodle","id":"CVE-2022-0334"},"packages":[{"ecosystem":"Bitnami","fixed":["3.8.10","3.9.12","3.10.9","3.11.5"],"introduced":["0","3.9.0","3.10.0","3.11.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2022-0333"},{"ecosystem":"Packagist","fixed":["3.10.8"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m434-m5pv-p35w"},{"ecosystem":"Packagist","fixed":["3.10.8"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m434-m5pv-p35w"},{"ecosystem":"Packagist","fixed":["3.11.5"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m434-m5pv-p35w"},{"ecosystem":"Packagist","fixed":["3.11.5"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m434-m5pv-p35w"},{"ecosystem":"Packagist","fixed":["3.9.11"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m434-m5pv-p35w"},{"ecosystem":"Packagist","fixed":["3.9.11"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m434-m5pv-p35w"}],"prev":{"headline":"SQL injection in Moodle","id":"CVE-2022-0332"},"products":["moodle"],"published":"2022-01-25","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Managers can improperly access or modify user-level calendar events due to insufficient permission checks in Moodle.","url":"https://insights.sbomify.com/CVE-2022-0333/"}