CVE-2022-0334 Insufficient user authorization in Moodle
Attackers can view grade reports for courses without proper authorization due to insufficient capability checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-0334?
CVE-2022-0334 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 25 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. Insufficient capability checks could lead to users accessing their grade report for courses where they did not have the required gradereport/user:view capability.
Which versions are affected by CVE-2022-0334?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.11 |
moodle/moodle Packagist | All versions | 3.9.11 |
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.11 | 3.11.5 |
moodle/moodle Packagist | From 3.11 | 3.11.5 |
1 more packages
moodle Bitnami | All versions | 3.8.10, 3.9.12, 3.10.9, 3.11.5 |
Products include Moodle Moodle.
How do I fix CVE-2022-0334?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.11, 3.10.8 or 3.11.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-0334 being exploited?
There is no known exploitation of CVE-2022-0334 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2022-0334, GHSA-93pj-4p65-qmr9, UBUNTU-CVE-2022-0334.