CVE-2022-0335 Cross Site Request Forgery in Moodle
Attackers can force authenticated users to delete badge alignments via CSRF due to missing token checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-0335?
CVE-2022-0335 is a high-severity vulnerability in Moodle Moodle, published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The "delete badge alignment" functionality did not include the necessary token check to prevent a CSRF risk.
Weakness: CWE-352
Which versions are affected by CVE-2022-0335?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.11 | 3.11.5 |
moodle/moodle Packagist | From 3.11 | 3.11.5 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
1 more packages
moodle Bitnami | All versions | 3.8.10, 3.9.12, 3.10.9, 3.11.5 |
Products include Moodle Moodle.
How do I fix CVE-2022-0335?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.5 or 3.9.11.
Is CVE-2022-0335 being exploited?
There is no known exploitation of CVE-2022-0335 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2022-0335, GHSA-xpfv-89vg-r562, UBUNTU-CVE-2022-0335.