# CVE-2022-0338: Insertion of Sensitive Information into Log File in delgan/loguru

> Attackers can access sensitive information stored in log files generated by the loguru Python library.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jan 2022
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-0338, GHSA-39ph-wr67-j4xq, PYSEC-2022-14, UBUNTU-CVE-2022-0338

## What is CVE-2022-0338?

CVE-2022-0338 is a medium-severity vulnerability in delgan/loguru, published on 25 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insertion of Sensitive Information into Log File in Conda loguru prior to 0.5.3.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2022-0338?

3 open source packages ship an affected version, including loguru. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loguru` | PyPI | All versions | 0.5.3 |
| `loguru` | PyPI | All versions | 0.5.3 |
| `loguru` | PyPI | All versions | 0.5.3 |

Products: Loguru Project Loguru.

## How do I fix CVE-2022-0338?

Upgrade loguru to 0.5.3 or later.

## Is CVE-2022-0338 being exploited?

There is no known exploitation of CVE-2022-0338 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0338 and fix it if it is affected.

What it is: CVE-2022-0338 is a medium-severity vulnerability in delgan/loguru, published on 25 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0338 in the wild and no public exploit code.

Affected packages and fixed versions:
- loguru (PyPI): affected all versions; fixed in 0.5.3
- loguru (PyPI): affected all versions; fixed in 0.5.3
- loguru (PyPI): affected all versions; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0338/ (Markdown: https://insights.sbomify.com/CVE-2022-0338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0338
- OSV: https://osv.dev/vulnerability/CVE-2022-0338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0338/
Summaries are generated and may contain mistakes; the official description above is the record.
