{"answers":{"affected":"2 open source packages ship an affected version, including vditor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0341 in the wild and no public exploit code.","fix":"Upgrade vditor to 3.8.11 or later.","what":"CVE-2022-0341 is a medium-severity cross-site scripting vulnerability in vanessa219/vditor, published on 14 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0341 and fix it if it is affected.\n\nWhat it is: CVE-2022-0341 is a medium-severity cross-site scripting vulnerability in vanessa219/vditor, published on 14 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0341 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vditor (npm): affected all versions; fixed in 3.8.11\n- vditor (npm): affected all versions; fixed in 3.8.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0341/ (Markdown: https://insights.sbomify.com/CVE-2022-0341/index.md)","id":"CVE-2022-0341","markdown":"https://insights.sbomify.com/CVE-2022-0341/index.md","name":"CVE-2022-0341","record":{"aliases":["GHSA-pq37-4c4g-v38c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JavaScript Markdown Editor","requires_auth":"low_privilege","summary":"Stored Cross-Site Scripting in the vditor library allows attackers to inject malicious scripts, potentially leading to session hijacking or data theft.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"vditor","vendor":"b3log"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - Stored in GitHub repository vanessa219/vditor prior to 3.8.12.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in vanessa219/vditor","id":"CVE-2022-0341","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Auth bypass in ATP series firmware","id":"CVE-2022-0342"},"packages":[{"ecosystem":"npm","fixed":["3.8.11"],"introduced":["0"],"last_affected":[],"package":"vditor","purl":null,"source":"GHSA-pq37-4c4g-v38c"},{"ecosystem":"npm","fixed":["3.8.11"],"introduced":["0"],"last_affected":[],"package":"vditor","purl":"pkg:npm/vditor","source":"GHSA-pq37-4c4g-v38c"}],"prev":{"headline":"Server-Side Request Forgery (SSRF) in janeczku/calibre-web","id":"CVE-2022-0339"},"products":["vanessa219/vditor"],"published":"2022-03-14","related":[{"cvss_score":6.8,"headline":"Cross-site Scripting (XSS) - Stored in vanessa219/vditor","id":"CVE-2021-4103","kev_date_added":null,"published":"2022-01-23"},{"cvss_score":6.1,"headline":"Vditor allows Cross-site Scripting via an attribute of an `A` element","id":"CVE-2024-34449","kev_date_added":null,"published":"2024-05-03"},{"cvss_score":6.1,"headline":"vditor vulnerable to Cross-site Scripting","id":"CVE-2021-32855","kev_date_added":null,"published":"2023-02-20"},{"cvss_score":6.1,"headline":"Cross-site Scripting (XSS) - Stored in vanessa219/vditor","id":"CVE-2022-0350","kev_date_added":null,"published":"2022-03-31"},{"cvss_score":5.9,"headline":"Path traversal in n/a","id":"CVE-2024-39150","kev_date_added":null,"published":"2024-07-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["vanessa219"]},"summary":"Stored Cross-Site Scripting in the vditor library allows attackers to inject malicious scripts, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2022-0341/"}