# CVE-2022-0348: Cross-site Scripting (XSS) - Stored in pimcore/pimcore

> Attackers can inject malicious scripts into Pimcore CMS, potentially stealing user data or executing code in victim browsers.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8x44-pwr2-rgc6

## What is CVE-2022-0348?

CVE-2022-0348 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 27 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cross-site Scripting (XSS) - Stored in Packagist pimcore/pimcore prior to 10.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-0348?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.2.10 |
| `pimcore/pimcore` | Packagist | All versions | 10.2.10 |

Products: Pimcore Pimcore.

## How do I fix CVE-2022-0348?

Upgrade pimcore/pimcore to 10.2.10 or later.

## Is CVE-2022-0348 being exploited?

There is no known exploitation of CVE-2022-0348 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0348 and fix it if it is affected.

What it is: CVE-2022-0348 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 27 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0348 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.2.10
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0348/ (Markdown: https://insights.sbomify.com/CVE-2022-0348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0348
- OSV: https://osv.dev/vulnerability/CVE-2022-0348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0348/
Summaries are generated and may contain mistakes; the official description above is the record.
