CVE-2022-0355 Improper Removal of Sensitive Information Before Storage or Transfer in feross/simple-get
Attackers can access sensitive information due to improper removal before storage or transfer in the simple-get library.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-0355?
CVE-2022-0355 is a high-severity vulnerability in feross/simple-get, published on 26 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Removal of Sensitive Information Before Storage or Transfer in NPM simple-get prior to 4.0.1.
Weakness: CWE-212
Which versions are affected by CVE-2022-0355?
6 open source packages ship an affected version, including simple-get. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
simple-get npm | All versions | 2.8.2 |
simple-get npm | All versions | 2.8.2 |
simple-get npm | From 3.0.0 | 3.1.1 |
simple-get npm | From 3.0.0 | 3.1.1 |
simple-get npm | From 4.0.0 | 4.0.1 |
simple-get npm | From 4.0.0 | 4.0.1 |
Linux distribution packages (1)
bitwarden openSUSE:Tumbleweed | All versions | 2023.2.0-1.1 |
Products include Simple-Get Project Simple-Get.
How do I fix CVE-2022-0355?
Upgrade simple-get to a fixed version for your release line: 2.8.2, 3.1.1 or 4.0.1.
Is CVE-2022-0355 being exploited?
There is no known exploitation of CVE-2022-0355 in the wild and no public exploit code.
Sources
Also known as GHSA-wpg7-2c88-r8xv, openSUSE-SU-2024:12718-1.