{"answers":{"affected":"2 open source packages ship an affected version, including bytefury/crater. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0372 in the wild and no public exploit code.","fix":"Upgrade bytefury/crater to 6.0.0 or later.","what":"CVE-2022-0372 is a high-severity cross-site scripting vulnerability in crater-invoice/crater, published on 27 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0372 and fix it if it is affected.\n\nWhat it is: CVE-2022-0372 is a high-severity cross-site scripting vulnerability in crater-invoice/crater, published on 27 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-0372 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bytefury/crater (Packagist): affected all versions; fixed in 6.0.0\n- bytefury/crater (Packagist): affected all versions; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0372/ (Markdown: https://insights.sbomify.com/CVE-2022-0372/index.md)","id":"CVE-2022-0372","markdown":"https://insights.sbomify.com/CVE-2022-0372/index.md","name":"CVE-2022-0372","record":{"aliases":["GHSA-6vfw-74wr-3chh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Crater Invoice","requires_auth":"low_privilege","summary":"Stored Cross-Site Scripting in Crater Invoice allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"crater","vendor":"craterapp"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - Stored in Packagist bytefury/crater prior to 6.0.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in crater-invoice/crater","id":"CVE-2022-0372","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in GitLab","id":"CVE-2022-0373"},"packages":[{"ecosystem":"Packagist","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"bytefury/crater","purl":null,"source":"GHSA-6vfw-74wr-3chh"},{"ecosystem":"Packagist","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"bytefury/crater","purl":"pkg:composer/bytefury/crater","source":"GHSA-6vfw-74wr-3chh"}],"prev":{"headline":"Information disclosure in GitLab","id":"CVE-2022-0371"},"products":["crater-invoice/crater"],"published":"2022-01-27","related":[{"cvss_score":8.8,"headline":"Unrestricted Upload of File with Dangerous Type in crater-invoice/crater","id":"CVE-2021-4080","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":7.5,"headline":"Improper Access Control in crater-invoice/crater","id":"CVE-2022-0203","kev_date_added":null,"published":"2022-01-26"},{"cvss_score":7.2,"headline":"Code injection in n/a","id":"CVE-2023-46865","kev_date_added":null,"published":"2023-10-30"},{"cvss_score":7.2,"headline":"Insecure deserialization of not validated module file in crater-invoice/crater","id":"CVE-2022-1032","kev_date_added":null,"published":"2022-03-29"},{"cvss_score":7.2,"headline":"Unrestricted Upload of File with Dangerous Type in crater-invoice/crater","id":"CVE-2022-1033","kev_date_added":null,"published":"2022-03-23"},{"cvss_score":7.2,"headline":"Unrestricted Upload of File with Dangerous Type in crater-invoice/crater","id":"CVE-2022-0242","kev_date_added":null,"published":"2022-01-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["crater-invoice"]},"summary":"Stored Cross-Site Scripting in Crater Invoice allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2022-0372/"}