{"answers":{"affected":"2 open source packages ship an affected version, including w-zip. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0401 in the wild and no public exploit code.","fix":"Upgrade w-zip to 1.0.12 or later.","what":"CVE-2022-0401 is a critical path traversal vulnerability in yuda-lyu/w-zip, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-0401 and fix it if it is affected.\n\nWhat it is: CVE-2022-0401 is a critical path traversal vulnerability in yuda-lyu/w-zip, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-0401 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- w-zip (npm): affected all versions; fixed in 1.0.12\n- w-zip (npm): affected all versions; fixed in 1.0.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0401/ (Markdown: https://insights.sbomify.com/CVE-2022-0401/index.md)","id":"CVE-2022-0401","markdown":"https://insights.sbomify.com/CVE-2022-0401/index.md","name":"CVE-2022-0401","record":{"aliases":["GHSA-fr6q-jv7j-35g3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"npm w-zip library","requires_auth":"none","summary":"An attacker can exploit a path traversal vulnerability in the w-zip library to read or modify arbitrary files on the system.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"w-zip","vendor":"w-zip_project"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Path Traversal in NPM w-zip prior to 1.0.12.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal in yuda-lyu/w-zip","id":"CVE-2022-0401","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Superforms \u003c 6.0.4 - Reflected Cross-Site Scripting","id":"CVE-2022-0402"},"packages":[{"ecosystem":"npm","fixed":["1.0.12"],"introduced":["0"],"last_affected":[],"package":"w-zip","purl":null,"source":"GHSA-fr6q-jv7j-35g3"},{"ecosystem":"npm","fixed":["1.0.12"],"introduced":["0"],"last_affected":[],"package":"w-zip","purl":"pkg:npm/w-zip","source":"GHSA-fr6q-jv7j-35g3"}],"prev":{"headline":"Denial of service in kernel","id":"CVE-2022-0400"},"products":["yuda-lyu/w-zip"],"published":"2022-02-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["yuda-lyu"]},"summary":"An attacker can exploit a path traversal vulnerability in the w-zip library to read or modify arbitrary files on the system.","url":"https://insights.sbomify.com/CVE-2022-0401/"}