{"answers":{"affected":"3 open source packages ship an affected version, including httpie. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-0430 in the wild and no public exploit code.","fix":"Upgrade httpie to 3.1.0 or later.","what":"CVE-2022-0430 is a low-severity vulnerability in httpie/httpie, published on 15 Mar 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-0430 and fix it if it is affected.\n\nWhat it is: CVE-2022-0430 is a low-severity vulnerability in httpie/httpie, published on 15 Mar 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-0430 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- httpie (PyPI): affected all versions; fixed in 3.1.0\n- httpie (PyPI): affected all versions; fixed in 3.1.0\n- httpie (PyPI): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-0430/ (Markdown: https://insights.sbomify.com/CVE-2022-0430/index.md)","id":"CVE-2022-0430","markdown":"https://insights.sbomify.com/CVE-2022-0430/index.md","name":"CVE-2022-0430","record":{"aliases":["DEBIAN-CVE-2022-0430","GHSA-6pc9-xqrg-wfqw","PYSEC-2022-167","UBUNTU-CVE-2022-0430"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"HTTP client tool","requires_auth":"high_privilege","summary":"An attacker can access sensitive information exposed by the HTTPie client tool, requiring users to upgrade to a secure version.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"httpie","vendor":"httpie"}],"cvss":{"score":2.4,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie","id":"CVE-2022-0430","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Google Pagespeed Insights \u003c 4.0.4 - Reflected Cross-Site Scripting","id":"CVE-2022-0431"},"packages":[{"ecosystem":"PyPI","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"httpie","purl":null,"source":"GHSA-6pc9-xqrg-wfqw"},{"ecosystem":"PyPI","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"httpie","purl":"pkg:pypi/httpie","source":"GHSA-6pc9-xqrg-wfqw"},{"ecosystem":"PyPI","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"httpie","purl":"pkg:pypi/httpie","source":"PYSEC-2022-167"}],"prev":{"headline":"WP Cerber Security, Anti-spam \u0026 Malware Scan \u003c 8.9.6 - Unauthenticated Stored Cross-Site Scripting","id":"CVE-2022-0429"},"products":["httpie/httpie"],"published":"2022-03-15","related":[{"cvss_score":8.8,"headline":"Open Redirect in httpie","id":"CVE-2019-10751","kev_date_added":null,"published":"2019-08-23"},{"cvss_score":7.4,"headline":"HTTPie allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack","id":"CVE-2023-48052","kev_date_added":null,"published":"2023-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["httpie"]},"summary":"An attacker can access sensitive information exposed by the HTTPie client tool, requiring users to upgrade to a secure version.","url":"https://insights.sbomify.com/CVE-2022-0430/"}