# CVE-2022-0436: Path Traversal in gruntjs/grunt

> An attacker can exploit a path traversal vulnerability in the Grunt task runner to read or modify arbitrary files on the system.

- **Severity:** High 7.1 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 2 Aug 2024
- **Also known as:** AZL-45141, DEBIAN-CVE-2022-0436, DLA-3386-1, GHSA-j383-35pm-c5h4, OESA-2022-1638, UBUNTU-CVE-2022-0436

## What is CVE-2022-0436?

CVE-2022-0436 is a high-severity path traversal vulnerability in gruntjs/grunt, published on 12 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-0436?

2 open source packages ship an affected version, including grunt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grunt` | npm | All versions | 1.5.2 |
| `grunt` | npm | All versions | 1.5.2 |

Products: Gruntjs Grunt.

## How do I fix CVE-2022-0436?

Upgrade grunt to 1.5.2 or later.

## Is CVE-2022-0436 being exploited?

There is no known exploitation of CVE-2022-0436 in the wild and no public exploit code.

## Other vulnerabilities in gruntjs/grunt

- [CVE-2022-1537](https://insights.sbomify.com/CVE-2022-1537/): Race Condition in Grunt (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0436 and fix it if it is affected.

What it is: CVE-2022-0436 is a high-severity path traversal vulnerability in gruntjs/grunt, published on 12 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0436 in the wild and no public exploit code.

Affected packages and fixed versions:
- grunt (npm): affected all versions; fixed in 1.5.2
- grunt (npm): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0436/ (Markdown: https://insights.sbomify.com/CVE-2022-0436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0436
- OSV: https://osv.dev/vulnerability/CVE-2022-0436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0436/
Summaries are generated and may contain mistakes; the official description above is the record.
