# CVE-2022-0472: Unrestricted Upload of File with Dangerous Type in jsdecena/laracom

> Attackers can upload malicious files to execute arbitrary code on the server hosting the Laracom e-commerce application.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-5q5w-mqp6-g2gh

## What is CVE-2022-0472?

CVE-2022-0472 is a high-severity vulnerability in jsdecena/laracom, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unrestricted Upload of File with Dangerous Type in Packagist jsdecena/laracom prior to v2.0.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-0472?

2 open source packages ship an affected version, including jsdecena/laracom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsdecena/laracom` | Packagist | All versions | 2.0.9 |
| `jsdecena/laracom` | Packagist | All versions | 2.0.9 |

Products: Laracom Project Laracom.

## How do I fix CVE-2022-0472?

Upgrade jsdecena/laracom to 2.0.9 or later.

## Is CVE-2022-0472 being exploited?

There is no known exploitation of CVE-2022-0472 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-0472 and fix it if it is affected.

What it is: CVE-2022-0472 is a high-severity vulnerability in jsdecena/laracom, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-0472 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsdecena/laracom (Packagist): affected all versions; fixed in 2.0.9
- jsdecena/laracom (Packagist): affected all versions; fixed in 2.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-0472/ (Markdown: https://insights.sbomify.com/CVE-2022-0472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-0472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-0472
- OSV: https://osv.dev/vulnerability/CVE-2022-0472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-0472/
Summaries are generated and may contain mistakes; the official description above is the record.
