CVE-2022-0477 Denial of service in GitLab

Medium 4.9 Published Updated

Attackers can cause a Denial of Service in GitLab by sending specific bulk requests to delete packages from registries.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-0477?

CVE-2022-0477 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 25 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 11.9 before 14.5.4, all versions starting from 14.6.0 before 14.6.4, all versions starting from 14.7.0 before 14.7.1. GitLab was not correctly handling bulk requests to delete existing packages from the package registries which could result in a Denial of Service under specific conditions.

Which versions are affected by CVE-2022-0477?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.9.014.5.4, 14.6.4, 14.7.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-0477?

Upgrade gitlab to a fixed version for your release line: 14.5.4, 14.6.4 or 14.7.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-0477 being exploited?

There is no known exploitation of CVE-2022-0477 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-0477, GHSA-3hmc-2fvj-7wmx.

Is CVE-2022-0477 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free